How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask sebastian manrique Your Own Question
sebastian manrique
sebastian manrique, Auto Mechanic
Category: Car
Satisfied Customers: 2966
Experience:  Director Ejecutivo at Multiservicios Cruz de las Mercedes
100564933
Type Your Car Question Here...
sebastian manrique is online now

Put new glowplugs in a 2.0 xtype and it won't start, New

This answer was rated:

Put new glowplugs in a 2.0 xtype and it won't start
JA: Have you checked the battery, particularly the terminal connections? Are they corroded?
Customer: New battery
JA: What year is your X-Type?
Customer: 2005
JA: Are you fixing your X-Type yourself? What have you tried so far?
Customer: Yes checked all connections had battery off locked it and unlocked it spins over but won't fire
JA: Is there anything else the Mechanic should know before I connect you? Rest assured that they'll be able to help you.
Customer: No

Hello, I am Jose Sebastian. Your automotive expert, It's a pleasure to me to attend your question. Thank you very much for trust in just answer.

Customer: replied 16 days ago.
Have you any suggestions on my problem
Customer: replied 16 days ago.
Have you any suggestions

Dear customer, it may be that when touching the injection system, air entered the injection system and you will need to perform a bleed process, anyway I recommend you verify that the fuses and relays related to the glow plug system have been checked because sometimes when they replace these components can burn out.

Finally, it is good to perform a factory data reset without a diagnostic tool, if you do not have one, you can try from the battery, this is done disconnecting the negative connector leaving the positive connected for 30 seconds, but the ideal is to do it through the diagnostic tool because many times the battery reset doesn't work.

Dear customer, for the moment I can't take calls but we can keep chatting here in the platform

Customer: replied 16 days ago.
All fuses etc ok not touched the injectors only had the Inlet manifold off

Dear customer, try to do a manual reset from the battery, i might be an error code generated that is causing a limp mode, disabling the ignition, even though it is a 2005 model, these models can have these protection systems.

On the other hand, if the manual reset does not work, we need to know what error code could have been generated, for example if we have an error code related to low pressure in the fuel injection system something could have happened in the injection system when the procedure was donem

If we have problems at the fuel glow plugs, perhaps the plugs are defective or they are not giving adequate power to properly preheat the fuel.

As I do not know the procedure that was carried out, it is good to do the diagnosis and share the error code to help you in a more accurate way, but I repeat, start with the battery reset to see if this corrects the problem.

sebastian manrique and other Car Specialists are ready to help you