How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Mechanic
Category: Car
Satisfied Customers: 42842
Experience:  Technical Consultant at Just Answer
14928985
Type Your Car Question Here...
Pete is online now

I have a 2008 LDV maxus 2.5, sometimes when I try to start

This answer was rated:

I have a 2008 LDV maxus 2.5, sometimes when I try to start it the EDC light flashes, all other dash lights work as they should but it won't engage the starter motor, reading a scan tool the error codes are PO322 ignition/Dist Engine speed input no signal & code PO722 Output speed sensor circuit no signal, I don't know what these mean, can you help ?
JA: Have you checked the fuses? The dashboard bulbs?
Customer: yes everything works as they should
JA: What is the make/model of your car?
Customer: LDV Maxus 2.5
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: No, I have no idea what to do
JA: Is there anything else the Mechanic should know before I connect you? Rest assured that they'll be able to help you.
Customer: no thank you

Welcome to JustAnswer. Thank you for contacting us for assistance with your vehicle. I'm Pete. I will be happy to assist you with your question. May I ask to whom I have the pleasure of speaking with today?

Customer: replied 2 months ago.
Hi Pete, I'M Shaun

Hello Shaun. Nice to hear from you today! I'm sorry to hear you are having this problem. I know this can be frustrating.

Have you tried to clear the fault codes with the scan tool then cycle the ignition off for a few minutes and then back on to see if the codes return as well as see if the engine starts and runs then at all?

Customer: replied 2 months ago.
I have tried to clear the codes but the scan tool won't clear them, the codes clear when the EDC light stops flashing
Customer: replied 2 months ago.
I've disconnected the battery & left it for 30 mins but it has no affect on the EDC

Thank you for your reply and that information as this does help me better understand the situation.

Please give me one moment to type out some info for you. I’ll be right back!

Customer: replied 2 months ago.
Ok thanks

You are welcome. Thank you for holding Shaun!

The first code tells me that there is a fault with the engine speed sensor which is commonly caused by the crankshaft position sensor. When this sensor acts up or fails it will cause issues with the engine itself not being able to start. I suspect that this sensor is causing the no-start issue to where it has to be replaced. This sensor can cost around $200 to have replaced. The second code indicates an issue with the output speed sensor at the transmission/gearbox itself. This occurs when the sensor has an internal electrical fault needing to be replaced or when there is a wiring issue leading to the sensor itself.

Both of these codes need to be looked into and tested further and are best performed by a shop or dealer using their test equipment and diagrams/procedures to locate the issues. In most cases, it is the output speed sensor and the engine crankshaft sensor that has to be replaced to resolve both codes and the no start issue.

Customer: replied 2 months ago.
Ok thanks Pete very helpful

You are most welcome!

Glad I could be of some help! I hope everything works out well for you! If there are any additional questions on this issue that should arise, please feel free to reply and ask!

Thank you for choosing Just Answer for your questions. Have a great day!

Customer: replied 2 months ago.
Will do & thanks again

Thanks and you are most welcome!

Pete and other Car Specialists are ready to help you