How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Engineer
Category: Electronics
Satisfied Customers: 2136
Experience:  Over 20 years of experience in the Electronics and IT industries.
30970729
Type Your Electronics Question Here...
Pete is online now

I have an apple iMac which has just been upgraded to 10.15 &

Customer Question

hi I have an apple iMac which has just been upgraded to 10.15 & know I cant use my printer to scan. my mc no is MFC-J5625DW Im told by apple I need a 64 bit program of you to get it working
JA: Is there an error code on your printer when you try to scan?
Customer: using control centre I get this message The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.
JA: When did you last update the printer driver software?
Customer: just tried no luck
JA: Anything else you want the Printer Expert to know before I connect you?
Customer: no
Submitted: 1 year ago.
Category: Electronics
Expert:  *ElectronicsTech replied 1 year ago.

Hi,
My name is***** am sorry to hear that you are having this issue.
I will be glad to assist you with this.
My goal is to give you the best experience possible!

The TWAIN scanner driver (TWAIN Driver) is supported by macOS v10.15.x in some moldes. For ADS models, the Scanner Driver download is here.https://support.brother.com/g/s/id/os/macintosh.html#mfc-j