How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask dresteve2000 Your Own Question
dresteve2000
dresteve2000, Customer Service
Category: Electronics
Satisfied Customers: 1640
Experience:  Electronics expert.
71208907
Type Your Electronics Question Here...
dresteve2000 is online now

Purchased ELEHOT Humidifier some months ago, initially it

Customer Question

Purchased ELEHOT Humidifier some months ago, initially it was OK but now shows RED light when turned ON.
JA: What's the brand and model of your product?
Customer: ELEHOT HUMIDIFIER- Model No QLS-T803. Cleaned inside, our water is soft, ensured float is working and ensure sufficient water is in vessel. Each time I have emptied vessel, put in front of radiator overnight, I have tried this for the last 1 month and red still alert problem.
JA: What have you tried so far?
Customer: Leaved it overnight empty with water in front of radiator to ensure there is no water inside and dry, have done this on 5 occasions.
JA: Anything else you want the Electronics Expert to know before I connect you?
Customer: NO
Submitted: 21 days ago.
Category: Electronics
Customer: replied 21 days ago.
Not interested in wait times, need solution NOW. All documents I have none, just this piece of kit that doesn't work
Expert:  dresteve2000 replied 21 days ago.

Hello, my name is ***** ***** I'm here to help you with this issue.

Expert:  dresteve2000 replied 21 days ago.

Let me review your question and get you an answer quickly.

Expert:  dresteve2000 replied 21 days ago.

Okay

Expert:  dresteve2000 replied 21 days ago.

There are a few things to check that would cause the empty light to go on:

  • Please rinse the lid on the bottom of the tank. After you rinse it with warm water, dry it and then push the spring on the outside of the lid, it should move easily. Check the inside of the lid and make sure the rubber gasket is securely in place. When twisting the lid onto the tank, please make sure that it is not over-tightened
  • On the base of the humidifier to the side of the ultrasonic disk is a small white plastic pole with a washer-ring around it. This is the float, make sure it moves easily up and down the pole. Tap the base of the machine on a hard surface. This will clear any air bubbles inside of the machine should there be any
  • Reassemble the humidifier, use room temperature water in the tank and let run for 30-40 minutes. Please make sure the humidifier is on a flat level surface, no carpeting or towel underneath
Expert:  dresteve2000 replied 21 days ago.

Please review that list and let me know if you've tried checking that rubber gasket and ultrasonic disk.

Customer: replied 21 days ago.
Think you are looking at a different model, no gasket on lid. The unit has be cleaned numerous occasions. Incidentally
Expert:  dresteve2000 replied 21 days ago.

Let me double check your model, one minute.

Customer: replied 21 days ago.
Don’t like this way of purchasing, goodbye
Expert:  dresteve2000 replied 21 days ago.

Is there a "O" shaped ring on the back of the device?