How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Engineer
Category: Electronics
Satisfied Customers: 74000
Experience:  Electronics Engineer
32989067
Type Your Electronics Question Here...
Richard is online now

I can't get my DVD player BD-C6500 to work - the error

This answer was rated:

I can't get my DVD player BD-C6500 to work - the error message "Anynet device is not connected. There are just two connection to the player - HDMI out and the permanent wired -in cable.
JA: What does your TV screen look like when you try to connect your BD-C6500? Is there anything at all displayed?
Customer: What's missing!!??
JA: The Video Technician will be able to walk you through that. Is your BD-C6500 connected to the TV, or is it connected to a power outlet?
Customer: There are just two connections - one to the TV, the other to power
JA: Anything else you want the Video Expert to know before I connect you?
Customer: Should there be another connection, if so from what to what??

Thank you for your question, my name is ***** ***** I look forward to assisting you.

I’m sorry to hear you're having trouble with your player. I know that can be frustrating. Hopefully, we can get this resolved quickly.

Can you please remove the power to the player (so unplug it from the power socket)

Then wait 10 minutes, connect the power again to the player and tell me please if it is now operating correctly.

Let me know the results please

Customer: replied 1 month ago.
Tried switching off for ten minutes - same error message

Go to the menu on the player, then system setup and choose Reset

Once it has Reset, follow the onscreen instructions and setup the player again

Tell me how it then functions please

Customer: replied 1 month ago.
I CANNOT GETE THE MENU UP!! THE ERROR MESSAGE IS THE SAME AS IT WAS RIGHT AT THE BEGINNING "ANYNET+ DEVICE IS NOT CONNECT!! As I asked before, should tere be another connection rather than just the mains and one to the TV??

No, just the TV and mains is enough

Can you please test the remote following the instructions on my link below

https://www.youtube.com/watch?v=UMPoifERrNs

This will allow is to see if the remote is actually functioning or if it is the TV that is at fault

Let me know the results please

Customer: replied 1 month ago.
Sorry, tied up on family crisis! Will try later!!
Customer: replied 1 month ago.
Hi! Tried this, remote seems to be working on this yest
Customer: replied 1 month ago.
Oops! “test” not yest!!
Customer: replied 1 month ago.
Remote apparently working OK, What noW??
Customer: replied 1 month ago.
11.10am 12th May Hi! Any other ideas, or do we give up??
Customer: replied 1 month ago.
I give up!!

It is the internal mainboard that has faulted.

I am really sorry about this and you are going to have to return the unit to have it replaced. It will be covered by the warranty if this has not expired, and the replacement will be done at no cost to you.

I am really sorry about this, and if you have problems, or would like any additional information or assistance, please do not hesitate to let me know.

Thank you

Customer: replied 1 month ago.
Thanks for trying! I very much think it is out of warranty, but it's probably old and tired - a bit like me!! regards, Colin

You are welcome Colin

Richard and other Electronics Specialists are ready to help you