How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Ford
Satisfied Customers: 23435
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Ford Question Here...
Matt is online now

When driving my transit connect in 5th gear, up a gradient,

Customer Question

when driving my transit connect in 5th gear, up a long gradient, the glow plug light comes on and the engine looses power. what might the fault be
Submitted: 5 months ago.
Category: Ford
Expert:  Matt replied 5 months ago.

Hello and welcome to Just Answer

as you have the glow plug light on then this means there will be a fault code stored in the computer

so the light this typically means one or more of the sensors has failed or has a faulty connection.

The fault can be something quite simple and nothing that’s going to stop the car to something quite major that will reduce engine power and possibly stop the engine

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method.

as there's a lack of power

I'd also check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.
then check the condition of the air filter and replace if in any doubt

If this is all OK then also check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If its a variable vane turbo (they’ll be an actuator on the turbo body - but not a wastegate) then check its vacuum pipework as above and check the connections to the diaphragm / solenoid valve

Also worth checking that the glow-plug relay is switching off as they can stick on and leave the glow plugs also on - on some cars this can force it into limp home

Expert:  Matt replied 5 months ago.

My goal is to give you the best advice that I can and I hope that I've helped today. Please remember to rate my service by selecting from the 5 stars at the top of the screen before you leave. If you need more help, use the reply box to let me know.
If you're not pleased, also let me know because rating bad does not result in a refund, there are better options. Rating now will not close this post nor prevent further replies
Thanks Matt

Expert:  Matt replied 5 months ago.

Hi
do you still need help?
Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! If you're not pleased, also let me know because rating bad does not result in a refund, there are better options. Rating now will not close this post nor prevent further replies
Thanks Matt