How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3912
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

Ford fiesta zetec 2007, lhd. The windscreen washer pump

This answer was rated:

Ford fiesta zetec 2007, lhd. The windscreen washer pump isn't working, wipers are working. No voltage at terminals to pump.
Assistant: Have you checked the fuses? Do you know if there is power to the wiper motor?
Customer: Wipers are working.
Assistant: Are you fixing your Fiesta yourself? What have you tried so far?
Customer: Same fuse for both?
Assistant: Anything else you want the Mechanic to know before I connect you?
Customer: No thank you.

Hi there good afternoon o you and sorry for the delayed response

My name is***** would be happy to assist you Today

ok do you have the registration and vin number of your vehicle so I can check some details

kindest regards ***** *****

brian

Customer: replied 7 months ago.
BF57ZZM WF0HXXWPJH7Y89222
Customer: replied 7 months ago.
Have just fitted new pump, no joy. Wipers working.

Hi there good evening to you and sorry for the delay in responding

ok the system uses a switch polarity system to operate the pump clockwise and anti clockwise for front and rear washers

this comes from the wiper /washer switch

Example - in your vehicle when you work the front wipers the switch sends an earth out of pin 2 (white and black wire)

And a feed out of pin 4 (yellow/black wire )

when you select the rear washers it reverses the polarity on the same pins

so you need to check across pins 2&4 for 12 volts when you work the washers either way

This must be the first check we carry out

If you need any further help or technical assistance going forward

please let me know and I will do my upmost to assist you

If you are satisfied with my answer /advice thus far

PLEASE REMEMBER TO RATE MY ANSWER

as is how iam Accredited for my advice and to build my online profile

This post /discussion will still stay open

Kind regards ***** ***** and have a nice day

positive feedback/bonuses Is kindly appreciated

Kindest regards ***** *****

Brian

Customer: replied 6 months ago.
Hi, yes there's 12v out between pins 2 and 4 with wiper switch reversing polarity.

Hi thanks

ok this rules the switch out as it’s doing it’s job of feeding the pump and reversing the polarity

the wiring from the switch runs through connector c810 at pins 11 and 12

Connector c810 is located in the drivers footwell (this may be different on LHD )

It shows it on the same side as the GEM module ( this is the module with 5 different coloured plugs )

I have attached an image of the c810 connector to give you assistance

If you need any further help or technical assistance going forward

please let me know and I will do my upmost to assist you

If you are satisfied with my answer /advice thus far

PLEASE REMEMBER TO RATE MY ANSWER

as is how iam Accredited for my advice and to build my online profile

This post /discussion will still stay open

Kind regards ***** ***** and have a nice day

positive feedback/bonuses Is kindly appreciated

Kindest regards ***** *****

Brian

Customer: replied 6 months ago.
It's OK it is a rhd, my bad.

Ok it will be on drivers side footwell

kindest regards ***** *****

brian

Customer: replied 6 months ago.
I can see the GEM but not that connector.

Hi did you remove the footwell trims

Customer: replied 6 months ago.
Removed the facia below steering wheel.
Is it behind trim at left in driver footwell?

Should be behind the lower footwell trim that curves up towards the GEM if not try the other side as there’s a few different diagrams

regards brian

From memory these were prone for corrosion due to moisture ingress

Customer: replied 6 months ago.
Voltage good at connector, +/- 12v.

Hi thanks

ok you will need to trace the wiring from here to the pump as this is the only connector online of the loom

This indicates there is a wiring issue between here and the pump

Check nearer the pump and work backward

kindest regards ***** *****

brian

Customer: replied 6 months ago.
OK, will retest voltage at pump. I had the headlight assembly out on the driver's side on Monday, maybe I disturbed something, will investigate when I can.
Customer: replied 6 months ago.
One question: as there is a voltage at those outputs, does that mean the GEM is good?

Hi there good evening to you

the GEM is only used to command the wipers to work when the washer switch is pressed (this uses a feed back from the switch

the switch controls the reversed polarity feed to the washer pump

so if you have 12 volts either way at c810 then the switch is ok and it’s a wiring concern to the pump

If you need any further help or technical assistance going forward

please let me know and I will do my upmost to assist you

If you are satisfied with my answer /advice thus far

PLEASE REMEMBER TO RATE MY ANSWER

as is how iam Accredited for my advice and to build my online profile

Kind regards ***** ***** and have a nice tonight

positive feedback Is kindly appreciated

Kindest regards ***** *****

Brian

Gallagher99 and other Ford Specialists are ready to help you