How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Stephen Rothwell Your Own Question
Stephen Rothwell
Stephen Rothwell,
Category: Mercedes
Satisfied Customers: 154
Experience:  Director at Steve Rothwell Limited
106618989
Type Your Mercedes Question Here...
Stephen Rothwell is online now

My front parking sensor is coming on when bring the car to a

Customer Question

My front parking sensor is coming on when bring the car to a stop
JA: Which particular sensor are you asking about? And have any trouble codes been triggered?
Customer: No codes indicated , just all orange and red lights were coming on when stopping. Windscreen recently replaced and recalibrate, any connection
JA: What is the model/year of your Mercedes?
Customer: E350, 2010
JA: Are you fixing your E350 yourself? What have you tried so far?
Customer: No, I have an electrical and mechanical WarrantWise policy so I will hopefully get repair through that
JA: Anything else you want the Mechanic to know before I connect you?
Customer: No
Submitted: 16 days ago.
Category: Mercedes
Customer: replied 16 days ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call.
Customer: replied 16 days ago.
Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 16 days ago.
Earlier when I got to Inverness the fault changed to just 2 orange lights coming on, no alarm beeps but sensors definitely not working
Customer: replied 16 days ago.
P.S. rear sensors working fine
Expert:  Nicola-mod replied 16 days ago.
Hello,

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you!
Nicola
Customer: replied 16 days ago.
Keep looking for now
Thanks
Expert:  Stephen Rothwell replied 15 days ago.

Hi

Thank you for your question and sorry for the delay in replying.

My name is Steve and I am a fully qualified vehicle technician with over 30 years in the trade, hopefully I can help.

From the information i have there is no connection between the screen and the parking system on your vehicle.

From your description I believe this may just be a coincidence. The parking sensors are activated when the vehicle drops down to parking speed and I would suspect that the fault is either with one of the front sensors or the wiring connection to the sensor. It is possible that water may have contaminated the plug and caused a short within the system.

It may just need the plugs on each sensor removing and drying out, or it may need a new sensor, hopefully this will be covered by your warrantwise policy.

I hope this answers your question but do please feel free to ask me any further details.

If this does answer your question please click accept and rate me, this allows me to continue.

Even after clicking accept you can continue to ask further questions on the matter.

Many Thanks

Steve