How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Stephen Rothwell Your Own Question
Stephen Rothwell
Stephen Rothwell,
Category: Mercedes
Satisfied Customers: 881
Experience:  Director at Steve Rothwell Limited
106618989
Type Your Mercedes Question Here...
Stephen Rothwell is online now

I hope you can help, or advise me, with a problem I have

This answer was rated:

Hi, I hope you can help, or advise me, with a problem I have with rear wiper not working.
JA: Have you checked the fuses? Do you know if there is power to the wiper motor?
Customer: power was getting to the motor, and faulty motor was diagnosed, but now there is no power. Faulty relay, but having switched to try a different one, all I get is the rear wiper symbol flash up on the dashboard very briefly evry 5 seconds or so
JA: What is the model/year of your Mercedes?
Customer: 2009 S211
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: My stepson is an experienced former vehicle technician at Ford, but now works at JLR
JA: Anything else you want the Mechanic to know before I connect you?
Customer: I am very slow at typing and not overly mechanically minded
Customer: replied 17 days ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call.
Customer: replied 17 days ago.
Let me know if you need more information, or send me the service offer(s) so we can proceed.

Good day

My name is ***** ***** I am a fully qualified vehicle technician with over thirty years in trade hopefully I can help.

As the wiper motor has been replaced but no power is now reaching it, the two most likely problems are either the loom between the rear door and the body or the boot closure module.

The short loom between the body and the hatch may have a fractured wire, this is quite common and the wire should be checked for any damage.

The boot closure module controls the power to the rear wiper motor and if this has failed then it would explain why the wiper is not operating, the module is located to the n/s rear of the load area.

It may be necessary to check the system using the Mercedes STAR diagnostic system, this would pip point the problem.

I hope this answers your question but do please feel free to ask any further details by replying to this thread.

Many thanks

Steve

Stephen Rothwell and other Mercedes Specialists are ready to help you