How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike_a_mechanic Your Own Question
mike_a_mechanic
mike_a_mechanic, Mitsubishi Mechanic
Category: Mitsubishi
Satisfied Customers: 51
Experience:  17 years experience as a auto mechanic, foreign and domestic.5 years running my own repair business.
19374685
Type Your Mitsubishi Question Here...
mike_a_mechanic is online now

It wont start...last night sounded like battery running down

Customer Question

it wont start...last night sounded like battery running down as it turned over. Charged battery ( 3 months old) , checked 12.9 v across terminals. Now it there is nothing . Turn key everything lights up and works but no starter cycle
Assistant: Does the battery look like it's leaking? And does it have a strong smell -- like sulfur?
Customer: No new battery 3 mts old
Assistant: What is the model of your '12 Mitsubishi?
Customer: 3.2 D
Assistant: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Yes will sort myself if poss ( ex aircraft mech) , only had the vehicle 6 mths , no experience of this 4x4
Assistant: Anything else you want the mechanic to know before I connect you?
Customer: 2004 model ,
Submitted: 4 months ago.
Category: Mitsubishi
Expert:  Greg replied 4 months ago.
Hook up the voltage meter to the battery, then watch the voltage drop from the said 12.9 volts when cranking the engine .
Now if voltage drops below 10volts then replace the battery. If voltage is above 11 volts then repair battery starting circuit . Meaning cables and the starter itself which is probably the problem.
Check this out then please get back to me.
Rgds Greg
Customer: replied 4 months ago.
there is no cranking of the starter motor. On the pos cable that attaches to pos terminal there are x3 Fuses. The 80a fuse looks blown. Been trying to get it out ..any tips
Expert:  Greg replied 4 months ago.
Ok this fuse is held in with two 10 mm bolts you have to remove this first . Greg