Join the 9 million people who found a smarter way to get Expert help

Recent ABS questions

I have a 54 plate c class Mercedes aventgard and need to

Hi there I have a 54 plate c class Mercedes aventgard and need to know where to find the wheel sensor a position can you help

Read more

Marty

Vice President / Manager

Associate Degree

39,594 satisfied customers
Mercedes e320cdi 2009 w211.last week i had various lights

mercedes e320cdi 2009 w211.last week i had various lights come on showing abs ebs warning as well as cruise control not operational.Left it in to get diagnostics carried out .code showed a faulty Lhs sensor.This was fitted but lights still come on.At this point i noticed also that the gearbox seems to be unable to go past 4th gear(38mph) without overreving.In drive it does not appear to go up through the gears.I cant change from sport to comfort mode.No noise from gearbox ,no leaks. I have had the oil filter and oil changed but no difference.Can you give me some advice

Read more

Marty

Vice President / Manager

Associate Degree

39,594 satisfied customers
Does a C270 Avantgarde SE have both traction control and

Does a C270 Avantgarde SE have both traction control and ESP?? Can they be independently switched on/off??

Read more

Marty

Vice President / Manager

Associate Degree

39,594 satisfied customers
Martyr, I have a 2002 slk r170 230k (post face-lift) with 6

Hi Martyr, I have a 2002 slk r170 230k (post face-lift) with 6 speed manual transmission .About 6 months ago, I started having an intermittent bas/esp light coming on, with associated lack of cruise control, or abs or esp function, as to be expected. Often it was only on for a few minutes and would go off again of its own accord.About 3 months ago I had the car re-mapped and the guy informed me that intermittent nsf speed sensor failure code was stored in the tpu... Which would explain the issue, probably. However....Yesterday my speedometer failed intermittently also and again today.I understand that the abs/esp controller takes readings from the wheel sensors to allow it to do its thing. What concerns me is that the issue has progressed over time...My question is this: If the speedo has stopped function, does this mean that ALL 4 speed sensors have failed? Would this be more indicative of a faulty control unit than the sensors?I have also read that it could actually not be any of those but actually the rotation contact located just behind the wheel.(Ps I know that it sounds like I have been irresponsible to not get it fixed before, however I am not affluent and was stung by MB when they charged me 1200 quid to *not* fix my non operating roof last year, so I read up and looked at it myself, very easily identifying a broken cable in the rear folding pillar, which I then fixed myself for 76 pence for a length of wire! I don't have another 1200 pounds (or more) for them to not fix this!)

Read more

Marty

Vice President / Manager

Associate Degree

39,594 satisfied customers
2003 ml 270 auto. Stuck in park. When releasing gear shift

2003 ml 270 auto. Stuck in park. When releasing gear shift and engaging reverse or drive makes a heavy clunking noisePut back to park gear stick jammed

Read more

Marty

Vice President / Manager

Associate Degree

39,594 satisfied customers
I have a 2001 Mercedes C220 CDI. Kept going into limp mode

I have a 2001 Mercedes C220 CDI. Kept going into limp mode and discovered the primary catalytic converter was clogged up, removed and cleaned and also replaced the air filter. Have cleaned ERG valve and MAF sensor. reset all error codes.Then started getting a check coolant level and the radiator fan is running flat out and car now permanently in limp mode.Checked coolant level and it is fine, no leaks anywhere and car is not overheating, on the advice of someone else on here I disconnected the battery and went through an ECU master reset procedure. Still getting coolant level warning and now getting ESP warning as well. i have not driven the car as yet. Any ideas as to what is going on? Only had this car for 3 weeks and I just want to sort it so that i can get rid of it ASAP. I hate the thing with a vengeance and will never buy either a diesel car or a Mercedes ever again.

Read more

Matt

Engineer

Bachelor's Degree

30,114 satisfied customers
W140 1992 400sel abs light NOT illuminating when ignition

W140 1992 400sel abs light NOT illuminating when ignition key turned on before starting engine , all other warning lights are on and go off after starting as normal. Also rear brakes not working. Alternator is working ok as engine does not cut off when battery cable is removed. Is there a connection between the no abs light and the rear brakes not working.

Read more

Marty

Vice President / Manager

Associate Degree

39,594 satisfied customers
Im in nigeria, own mercedes benz class B200 turbo, its been

Im in nigeria, own mercedes benz B class B200 turbo, its been diagonosed with this fault 2732 and 1634. I was told no one can help me in Nigeria, what should I do?

Read more

Matt

Engineer

Bachelor's Degree

30,114 satisfied customers
My 2005 Mercedes ML 500 W164 has started self braking! ABS

My 2005 Mercedes ML 500 W164 has started self braking! ABS light comes on and brakes come on! What's going on? How can I fix it please?

Read more

Matt

Engineer

Bachelor's Degree

30,114 satisfied customers
View more mercedes questions
In The News