How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Technician
Category: TV
Satisfied Customers: 74729
Experience:  TV Engineer
32989067
Type Your TV Question Here...
Richard is online now

I have a son, I have a song tv and recently, I seemed to

Customer Question

I have a son
JA: What's the brand and model number of your TV? How old is it?
Customer: I have a song tv and recently, I seemed to lose the itv channels, so I retuned it and got 26, so I thought that's not right , so I returned again and have now lost all my channels . It picks up the Wi-Fi so I can get i player
JA: Does the TV menu work? Do you have the same problem on all sources/inputs?
Customer: Sony tv
JA: How long has this been an issue with your Sony? What happened right before this?
Customer: Other tv's in house work from same aerial
JA: Anything else you want the TV Expert to know before I connect you?
Customer: It was fine, like I say last week i noticed we weren't getting a signal for it programmes, thought it might be a glitch, but after a few days, still not improved, reason why I thought I would try to retune
Submitted: 1 year ago.
Category: TV
Customer: replied 1 year ago.
Sony KDL 40W 705C
Expert:  Richard replied 1 year ago.

Hi there and welcome to Just Answer, my name is ***** ***** I look forward to helping you.

I’m sorry to hear you're having trouble with your TV. I know that can be frustrating. Hopefully, we can get this resolved quickly.

Please note, a rating is only needed when we are finished.

Can you please remove the power to the TV and any other devices connecting to the TV such as a cable box ect (so unplug it from the power socket).

Then wait 10 minutes, connect the power again to the TV and connecting devices, turn it on and tell me please if it is now operating correctly.

Let me know the results please