How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, Vauxhall Technician
Category: Vauxhall
Satisfied Customers: 4750
Experience:  Fully qualified 19+yrs exp/self employed technician in the UK
13210289
Type Your Vauxhall Question Here...
Robert is online now

My 09 insignia is losing power when it gets up to temp and

Customer Question

My 09 insignia is losing power when it gets up to temp and the display says service soon. I have just had the boost sensor charged and the issues has occured again. It's also doesn't always stored the fault code p0234.
Assistant: Which particular sensor are you asking about? And have any trouble codes been triggered?
Customer: Boost sense in the from of the car above the rad
Assistant: What is the model of your '09 Vauxhall?
Customer: Insignia Sri
Assistant: Are you fixing your vehicle yourself? What have you tried so far?
Customer: No I got to a trusted mechanic. He serviced it yesterday and he said the fault code weren't stored as it was before a few weeks ago
Assistant: Anything else you want the mechanic to know before I connect you?
Customer: No it's just reasons for this with that code and what to get fixed to solve the problems first thing in the morning the car runs lovely just after it warms up and on high revs this issue sometimes occurs
Submitted: 6 months ago.
Category: Vauxhall
Expert:  Robert replied 6 months ago.

Hi.there..

P0234 is an overboost condition...id maybe check if your have replaced the boost control sensor with a genuine replacement.. check for the turbo wastegate sticking and the vacumm hose form control solenoid to turbo..maybe also too clean the usual culprits - EGR valve and boost sensor..

Customer: replied 6 months ago.
Many thanks I'll do that and see how it goes.
Expert:  Robert replied 6 months ago.

No problem at all...anything you'd like to ask then just continue on this post..in the meantime please ensure you have have left rating for me much appreciated..