How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Todd Green Your Own Question
Todd Green
Todd Green,
Category: Vauxhall
Satisfied Customers: 704
Experience:  Expert at Just Answer
57969284
Type Your Vauxhall Question Here...
Todd Green is online now

Getting a reading of 0.000v from the O2 sensor (Pre Cat) on

Customer Question

Getting a reading of 0.000v from the O2 sensor (Pre Cat) on my Vauxhaul Astra 1.4 (02 plate)
Odd time it's 0.045v but very rare.
STFT is 0%
LTFT is 25%
Is it likely that:
The 02 Sensor has failed and because the voltage from the sensor is so low the ECU is trying to make the mixture richer?
I've had a code for 02 sensor 1 bank 1 and also the 'spanner light' comes on with an error code pending or logged.
It's a 4 wire sensor and I've ordered one but because the odd reading of 0.045v I wondered about the integrity of the wiring rather than the sensor.
Am I following the right path.
Submitted: 5 months ago.
Category: Vauxhall
Expert:  Todd Green replied 5 months ago.

Hi there - I would unplug the sensor, and take some readings with a digital voltmeter - no analog meters for modern cars.

Expectations with the sensor unplugged - 2 wires are for the sensor heater - a power and ground - probably should see system voltage on one wire, ground on the other. The other two wires go to the computer - one should have a bias voltage of 450mv (0.450 v) and the other should be a ground back to the computer.

Hope that helps. Canuck